Doxy.me Loading Blank Page
Incident Report for Doxy.me Inc.
Postmortem

Summary of event: Doxy.me website was failing to load, providing users an "Oops" error message or white screen.

Business Impacts: Providers and Patients were unable to access the site to be able to have their appointments.

Root cause: On Wednesday, December 16th around 4pm and Thursday around 11am EST, we had an increase of web traffic that overloaded our servers. Our systems did not add additional servers in time to process the traffic.

How was the issue resolved: Additional servers were added to production to assist in sharing the web traffic.

Preventative next steps: We have added more servers, are improving our monitoring, and have reduced internal latency which also increases network capacity.

Posted Dec 22, 2020 - 09:26 EST

Resolved
This issue has been resolved. we will provide a Post Mortem in the coming days.
Posted Dec 17, 2020 - 13:31 EST
Monitoring
A fix has been implemented. We are continuing to monitor the situation and will provide a Post Mortem in the coming days.
Posted Dec 17, 2020 - 11:43 EST
Update
This is a large system issue and we are continuing to look for a resolution. The page is loading very slowly, and will load after two minutes. We do not have an ETA at this time.
Posted Dec 17, 2020 - 11:29 EST
Investigating
We are currently investigating an issue with Doxy.me's webpage not loading.
Posted Dec 17, 2020 - 11:10 EST
This incident affected: Doxy.me webpages.