Discussion board not responding https://discuss.doxy.me/
Incident Report for Doxy.me LLC
Resolved
The discussion board is now working again. Updates to follow
Posted May 18, 2020 - 12:48 EDT
Update
We are continuing to investigate this issue.
Posted May 18, 2020 - 12:28 EDT
Investigating
We are currently looking into this issue. This isn't impacting any patient/provider interactions.
Posted May 18, 2020 - 12:26 EDT
This incident affected: Discussion board.