Latency Preventing Patient Check-In
Incident Report for Doxy.me Inc.
Resolved
AWS has resolved the issue with the network load balancers and is showing their service is operating normally. We are no longer seeing latency spikes. This issue is now resolved.
Posted Feb 11, 2021 - 08:34 EST
Update
The vendor is continuing to monitor their system and has updated their status back to fully operational. AWS is continuing to roll out their updates to resolve the issue with their network load balancers. Our logged errors have been drastically reduced thanks to these efforts. We will continue to monitor this incident into tomorrow.
Posted Feb 10, 2021 - 18:25 EST
Update
The vendor has implemented a fix to route traffic around the failure in their system as a temporary fix. In addition, this incident appears to have been magnified by an incident at Amazon Web Services (AWS). AWS is currently rolling out a fix on their side to address problems with their Network Load Balancers. We are continuing to monitor this incident and are seeing a significant reduction in the errors being logged since these efforts have been announced.
Posted Feb 10, 2021 - 17:14 EST
Update
We are continuing to monitor this incident. The vendor is continuing to work on fixes to bring everything back to an operational status.
Posted Feb 10, 2021 - 16:32 EST
Update
We are continuing to monitor this incident. The vendor is continuing to work on fixes to bring everything back to an operational status.
Posted Feb 10, 2021 - 15:48 EST
Update
We are continuing to monitor this incident and are still seeing intermittent errors due to latency. Overall, the system continues to show a much quicker response time than it did earlier in the day. The vendor is continuing to work on fixes to bring everything back to an operational status.
Posted Feb 10, 2021 - 15:27 EST
Update
We are continuing to monitor this incident. The vendor is continuing to work on fixes to bring everything back to an operational status.
Posted Feb 10, 2021 - 15:00 EST
Update
The vendor is only seeing a few remaining service errors being logged on their side. They are continuing to address the elevated latency issues while we continue to monitor our API calls.
Posted Feb 10, 2021 - 14:33 EST
Update
We are continuing to monitor the incident. We are still seeing improvements as the vendor's system continues to recover. We will provide another update in 20 minutes.
Posted Feb 10, 2021 - 14:12 EST
Update
The vendor is reporting that their main functionality has been restored. We are still monitoring the API calls as they are continuing to recover from today's event. These generally take more time to return to normal. We will provide another update in 20 minutes.
Posted Feb 10, 2021 - 13:47 EST
Monitoring
We are continuing to monitor the latency issues with our check-in vendor as their statistics are trending in the right direction. Internally, we are intermittently able to check in and have calls, but we are also still seeing the server errors. We do not have an ETA for a fix to share at this time. We will provide another update in 20 minutes.
Posted Feb 10, 2021 - 13:26 EST
Update
We are continuing to investigate this issue. We are seeing patients are now able to check in, but are not showing up for the provider queue.
Posted Feb 10, 2021 - 12:25 EST
Investigating
We are currently investigating latency spikes that are preventing patients from checking in.
Posted Feb 10, 2021 - 11:56 EST
This incident affected: Doxy.me webpages.