Safari 14 Audio Problems
Incident Report for Doxy.me Inc.
Resolved
Apple has deployed an update to iOS and MacOS, upgrading to version 14.3 and 11.1 respectively on December 14th, 2020. This update has resolved the audio bug introduced by the recent updates to Safari. We recommend you update your browser to the latest version to ensure you are not impacted by the audio bug. You can do that by following these instructions for iPhone and iPad.

iOS Devices: https://support.apple.com/en-us/HT204204
MacOS: https://support.apple.com/en-us/HT201541
Posted Dec 15, 2020 - 10:24 EST
Monitoring
We recently identified an issue in Safari version 14.0.1 that is causing Static/clicking noises for the first minute or so, and then it goes to normal. It is not just us impacted, but all webRTC applications. We are waiting for Apple to release version 14.3 that fixes the issue.

Here are the best known workarounds:
1) Start chat with the patient and tell them the audio just needs 30-60 seconds to resolved.
2) Ask if they have another device at their disposal and use one of below browsers:

For Windows Laptop/Desk: Chrome, Edge, Firefox (No Internet Explorer)
For Mac Laptop/iMac: Chrome, Safari, Firefox
For iPhone/iPad: Safari Only at this time (This may have brief audio clicking)
For Android Mobile/Tablet: Chrome, Edge, Samsung, Firefox (No I.E.)
Posted Dec 03, 2020 - 09:01 EST
This incident affected: Doxy.me webpages.