Higher error rates and some customers not able to have video calls
Incident Report for Doxy.me Inc.
Resolved
Comcast has reported that the issue should be resolved for almost all customers: https://twitter.com/comcastcares/status/927636388517838848
Posted Nov 06, 2017 - 15:43 EST
Identified
Comcast Network Operations Center confirmed they're aware of the issue and working on fixing it, but didn't provide any more details. If you are a Comcast customer and are experiencing issues, try switching to a mobile device with 3G or LTE data plan as that should allow you to have a video call.

Some additional details here: https://www.theverge.com/2017/11/6/16614160/comcast-xfinity-internet-down-reports
Posted Nov 06, 2017 - 14:31 EST
Update
It appears to be isolated to Comcast customers as people all over the country are reporting websites either not loading, or loading very slowly: http://downdetector.com/status/comcast-xfinity
Posted Nov 06, 2017 - 14:11 EST
Investigating
Some customers have reported not being able to connect, and we are seeing higher error rates than normal in certain geographical regions. Other major websites have reported issues or downtime and this might be related to a larger event. We are investigating and will post updates as we learn more.
Posted Nov 06, 2017 - 13:52 EST