Doxy.me site not loading

Incident Report for Doxy.me Inc.

Resolved

We recently encountered an issue that prevented patients from appearing in their provider's waiting room queue. This issue has now been resolved, and patient check-in is functioning as expected. A post-mortem report will be provided in the coming days.
Posted Mar 05, 2025 - 14:30 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 05, 2025 - 13:57 EST

Update

System is returning back to normal. We are continuing to monitor the situation.
Posted Mar 05, 2025 - 13:57 EST

Investigating

We're currently investigating a reported system outage that's impacting patient check-in and provider account access.
Posted Mar 05, 2025 - 13:42 EST
This incident affected: Doxy.me API and Doxy.me webpages.