This incident has been resolved. All login and authentication services are now operating normally.
Posted Oct 29, 2025 - 14:22 EDT
Monitoring
Fix for the issue with auth CDN provider is applied, and login services on doxy.me are now recovering. We are continuing to monitor performance and accessibility across all regions to ensure full stability.
Components Affected: • Provider Sign-In • Authentication Service
Posted Oct 29, 2025 - 12:46 EDT
Investigating
We are currently investigating an issue affecting some provider logins on doxy.me. Users may experience a blank or unresponsive login page.
Initial investigation indicates that the issue originates from our authentication system, which is currently experiencing a global outage related to CDN configuration.
We’re actively monitoring the situation and working to ensure service stability.
Components Affected: • Provider Sign-In • Authentication Service
Posted Oct 29, 2025 - 12:22 EDT
This incident affected: Doxy.me API and Doxy.me webpages.