The disruption with Mandrill has been resolved. Email invitations sent using Invite Via are now being delivered as expected.
Posted Sep 01, 2026 - 15:12 EDT
Update
We are continuing to monitor for any further issues.
Posted Sep 01, 2026 - 14:48 EDT
Monitoring
Mandrill has implemented a fix. We’re monitoring email invitations sent using Invite Via to confirm they are being delivered as expected.
Posted Sep 01, 2026 - 14:46 EDT
Identified
We’ve confirmed that the issue affecting email invitations sent using Invite Via is related to a disruption with Mandrill. Both teams are actively working to restore email delivery.
Posted Sep 01, 2026 - 11:34 EDT
Investigating
We’re investigating an issue affecting email invitations sent through doxy.me using Invite Via. Some invitations may be delayed or not delivered.
This is a known issue related to a disruption with Mandrill, our third-party email delivery provider. Both our team and Mandrill’s team are actively working to resolve it.
Doxy.me remains available, and you can continue sharing your room link in other ways. We will provide updates as we learn more.