Chrome browser cannot hear person on Firefox browser
Incident Report for Doxy.me Inc.
Resolved
We rolled back the particular changed that caused the issue. Please refresh your page if you are still experiencing this problem.
Posted Jul 09, 2020 - 19:49 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 09, 2020 - 18:14 EDT
Investigating
We are investigating an issue where a person using the Chrome browser, cannot hear a person using the Firefox browser. We will update here in the next hour with any updates as to the root cause.

In the meantime, if both people use Firefox, or both people use Chrome they are able to hear each other fine.
Posted Jul 09, 2020 - 17:19 EDT
This incident affected: Doxy.me webpages.