Doxy.me Service Interruption
Incident Report for Doxy.me Inc.
Postmortem

Summary of event: On May 25th, Doxy.me experienced a database issue that resulted in 27 minutes of unplanned downtime from 2:03pm to 2:30pm ET.

Business Impacts: Sessions in progress were not impacted. The incident resulted in providers being unable to log in for their sessions. In addition, patients who were not already in the queue were unable to check in to their providers waiting room.

Root cause: A data import file was processed internally. While it was being processed, a series of long-running secondary server processes were triggered. Unfortunately, these processes built up in number, consuming additional server resources until the servers were backed up.

How was the issue resolved: The file was able to finish processing and the system self recovered.

Preventative next steps: We are optimizing the the long-running processes which will help prevent this scenario from happening again. In the short term, we are no longer running large data imports during peak business hours.

Posted Jun 02, 2023 - 13:36 EDT

Resolved
Doxy.me services continue to be stable. We are considering this incident resolved and will provide a post mortem within the few business days.
Posted May 26, 2023 - 12:01 EDT
Update
System levels have remained stable overnight. We are continuing to monitor the system performance and will provide another update by 12pm ET.
Posted May 26, 2023 - 09:00 EDT
Monitoring
We are seeing our system stabilizing. We are continuing to look into the incident and are going to continue to monitor the situation.
Posted May 25, 2023 - 15:06 EDT
Investigating
We are aware of an outage currently affecting doxy.me. This appears to affect sign-in, call connecting, and various other system services. Our team is currently investigating at this time. We will post an update as we know more.
Posted May 25, 2023 - 14:29 EDT
This incident affected: Doxy.me API.