Safari 15: Frozen Video Feed
Incident Report for Doxy.me LLC
Update
A workaround has been identified to get the video image unfrozen:
1) If the video display is frozen on Safari 15, try clicking the Gear Icon for Call Settings.
2) When the call settings open, click the “X” to close out the Call Settings.
3) When it closes the screen should no longer be frozen.
Posted Oct 01, 2021 - 14:54 EDT
Update
We are continuing to monitor for any further issues.
Posted Sep 23, 2021 - 17:27 EDT
Monitoring
We are aware of a bug introduced by the deployment of Safari 15 that is impacting all WebRTC systems. Many Safari 15 users may experience frozen video images while on calls with their clients or providers. If you experience frozen images during a call, please try another internet browser such as Google Chrome or Firefox.

We are working internally to see if there is anything we can do to help mitigate the issue. We are also anticipating the issues will be resolved in an upcoming update by Apple. We do not have any information from Apple regarding an expected fix date.
Posted Sep 23, 2021 - 17:27 EDT
This incident affects: Doxy.me webpages.