Error accessing doxy.me
Incident Report for Doxy.me LLC
Resolved
This incident has been resolved.
Posted Jul 17, 2020 - 19:24 EDT
Update
We are continuing to monitor for any further issues.
Posted Jul 17, 2020 - 18:39 EDT
Monitoring
Cloudflare has implemented a fix and they have provided this update:
"This afternoon we saw an outage across some parts of our network. It was not as a result of an attack. It appears a router on our global backbone announced bad routes and caused some potions of the network to not be available. We believe we have addressed the root cause and monitoring systems for stability now."

Doxy.me will continue to monitor the situation for any lingering issues with any of our service providers.
Posted Jul 17, 2020 - 18:13 EDT
Identified
We have been notified from an upstream service provider that the issue has been identified and a fix is being implemented.
Posted Jul 17, 2020 - 17:48 EDT
Update
We are continuing to investigate this issue.
Posted Jul 17, 2020 - 17:34 EDT
Investigating
We are currently investigating an issue impacting access to doxy.me at this time.
Posted Jul 17, 2020 - 17:33 EDT
This incident affected: Doxy.me webpages.