Doxy.me site not loading

Incident Report for Doxy.me Inc.

Resolved

The system issue preventing patient check-in and provider account access has been resolved. The doxy.me system is functioning as normal. Once our investigation is complete, a post-mortem will be provided.
Posted Dec 19, 2024 - 20:43 EST

Monitoring

The system is returning to normal. We are continuing to monitor the situation.
Posted Dec 19, 2024 - 17:19 EST

Investigating

We are currently investigating this issue.
Posted Dec 19, 2024 - 12:06 EST
This incident affected: Doxy.me API and Doxy.me webpages.