Doxy.me Not Loading on Older Browser Versions
Incident Report for Doxy.me Inc.
Postmortem

Summary of event: On January 10th, an update caused out-of-date browsers to not load doxy.me.

Business Impacts: Patients or providers using the impacted browsers were unable to access doxy.me.

Root cause: One of the software packages used in our code was updated on January 10th, 2023 at 08:20 AM UTC. The updated version was incompatible with and no longer supported older browser versions, including any versions older than the following:

  • Chrome: 93 (released August 31st, 2021)
  • Firefox: 92 (released September 7th, 2021)
  • Safari: 15.4 (released March 15th, 2022)
  • Edge:  93 (released August 3rd, 2021)

How was the issue resolved: Doxy.me released a fix that reverted the update to the software packages on January 11th, at 8:03 AM UTC.

Preventative next steps: We will be updating our internal system requirements and our supported browser policies. Once approved, we will increase our communication efforts with our customers to make it easier for them to recognize when they are using an out-of-date browser and how to update it. We will also shore up our testing coverage to better detect these problems in advance. Thank you for your patience.

Posted Jan 13, 2023 - 13:41 EST

Resolved
We have deployed a fix restoring functionality to the out of date browsers. We recommend keeping your devices and browsers up to date in general, but do apologize for any disruption this incident may have caused. We will share the post mortem within the next few business days.
Posted Jan 11, 2023 - 07:59 EST
Identified
We have determined the root cause for this incident and are currently testing a fix. At this time, we expect the fix to be deployed early tomorrow, between 3:00am and 7:00am EST (between 08:00 and 12:00 UTC).
Posted Jan 10, 2023 - 12:39 EST
Investigating
We are currently investigating an issue where older versions of web browsers (Safari, Chrome, Firefox, Edge) are not allowing doxy.me to load. Updating your browser to the latest version will allow doxy.me to load.

Browsers able to load doxy.me:
Safari 15.4 and newer
Chrome 93 and newer
Firefox 92 and newer
Edge 93 and newer

If you or your client is impacted at this time, our help article will help guide you to update.
Posted Jan 10, 2023 - 10:21 EST
This incident affected: Doxy.me webpages.