Doxy.me Loading Blank Page
Incident Report for Doxy.me Inc.
Postmortem
  • Summary of event: On Thursday October 8th, doxy.me experienced roughly 90 minutes of client downtime.
  • Business Impacts: Doxy.me waiting room pages failed to load. Users saw a blank screen, and were ultimately redirected to a “clinic does not exist” error message.
  • How was the issue resolved: We stopped and restarted the doxy.me services. This solved the immediate issue and service was restored.
  • Root cause: Connections to one of our vendors were staying open for too long without timing out. This used up the available connections until our service was no longer able to respond.
  • Preventative next steps: A solution is in progress and will be included in a future release.
Posted Oct 12, 2020 - 16:42 EDT

Resolved
We are marking this issue as resolved and we will post a full root cause analysis in the coming day.
Posted Oct 08, 2020 - 13:52 EDT
Monitoring
A fix has been implemented and the doxy.me application is now becoming accessible. We are continuing to monitor closely.
Posted Oct 08, 2020 - 13:26 EDT
Update
We still do not have the underlying cause identified. The doxy.me application is down and neither providers nor patients can access it. Our engineering team is working on this. We will continue to post updates frequently, but we still do not have an estimated time to resolution.
Posted Oct 08, 2020 - 12:47 EDT
Update
We are continuing to investigate this issue. There is no time estimate for recovery at this moment.
Posted Oct 08, 2020 - 12:30 EDT
Update
We are continuing to investigate this issue.
Posted Oct 08, 2020 - 12:04 EDT
Investigating
We have identified an issue with loading a blank page at this time and are working on a resolution, we will post updates here.
Posted Oct 08, 2020 - 11:54 EDT
This incident affected: Doxy.me webpages.