Services are operating normally. We're continuing to monitor the platform to ensure everything remains stable.
Posted Jul 16, 2026 - 07:26 EDT
Identified
We have identified the issue as a disruption affecting our authentication provider, caused by an ongoing AWS CloudFront incident. The website may remain accessible, but some users may be unable to log in or use certain platform functionality.
Our provider is actively implementing mitigations to bypass the affected CloudFront service, and we are closely monitoring their progress. We will provide another update as soon as more information becomes available.
Posted Jul 16, 2026 - 05:05 EDT
Investigating
We are currently investigating an issue causing partial service disruption. While the website remains accessible, some functionality is not working as expected, including authentication and login. Our team is actively working with our upstream provider to identify the root cause and restore full functionality as quickly as possible. We will provide updates as we learn more.
Posted Jul 16, 2026 - 04:10 EDT
This incident affected: Frontegg Authentication APIs, Frontegg Management APIs, and Frontegg Management Portal.