File Uploads and Service Startup Issues

Incident Report for Doxy.me Inc.

Resolved

The AWS issue has been resolved and all doxy.me services are now functioning normally.
Posted Oct 21, 2025 - 05:38 EDT

Update

The ongoing AWS issue continues to affect some doxy.me services. We’re closely monitoring the situation and will share updates as they are available.
Posted Oct 20, 2025 - 16:04 EDT

Investigating

A doxy.me partner, AWS, is experiencing an issue that is now impacting some provider sign-ins, site functionality, and file uploads. We’re monitoring AWS and will share updates as they become available.
Posted Oct 20, 2025 - 10:49 EDT

Update

A fix has been implemented by our AWS partner, and affected doxy.me services are recovering. File uploads and new session starts are operating normally, but we’re continuing to monitor to ensure full stability.
Posted Oct 20, 2025 - 06:20 EDT

Monitoring

A fix has been implemented by our AWS partner, and affected doxy.me services are recovering. File uploads and new session starts are operating normally, but we’re continuing to monitor to ensure full stability.
Posted Oct 20, 2025 - 06:20 EDT

Investigating

We’re investigating an issue causing file uploads (like check-in photos) to fail and preventing some new sessions from starting. Ongoing calls are working normally. The issue appears related to an AWS outage and we’re monitoring their progress.
Posted Oct 20, 2025 - 05:56 EDT
This incident affected: Amazon Web Services (AWS) (AWS lambda-us-east-1, AWS cloudfront, AWS lambda-us-east-2, AWS lambda-us-west-1, AWS lambda-us-west-2).